You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sec-keys/openpgp-keys-openwall/openpgp-keys-openwall-20210...

23 lines
647 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="OpenPGP keys used to sign Openwall software releases"
HOMEPAGE="https://www.openwall.com/signatures/"
SRC_URI="
https://www.openwall.com/signatures/openwall-offline-signatures.asc ->
297AD21CF86C948081520C1805C027FD4BDC136E.asc"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
S="${WORKDIR}"
src_install() {
local files=( ${A} )
insinto /usr/share/openpgp-keys
newins - openwall.asc < <(cat "${files[@]/#/${DISTDIR}/}")
}