You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-cpp/ms-gsl/ms-gsl-9999.ebuild

35 lines
738 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit cmake-utils git-r3
DESCRIPTION="Guideline Support Library implementation by Microsoft"
HOMEPAGE="https://github.com/Microsoft/GSL"
SRC_URI=""
EGIT_REPO_URI="https://github.com/Microsoft/GSL.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
IUSE="test"
RESTRICT="!test? ( test )"
# header only library
RDEPEND=""
DEPEND="test? ( dev-cpp/catch:1 )"
PATCHES=(
"${FILESDIR}/${PN}-1.0.0-use_system_catch-636828.patch"
"${FILESDIR}/${PN}-1.0.0-disable_Werror-644042.patch"
)
src_configure() {
local mycmakeargs=(
-DGSL_TEST=$(usex test)
)
use test && mycmakeargs+=( -DFORCE_SYSTEM_CATCH=ON )
cmake-utils_src_configure
}