You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/gluraw/gluraw-1.4.0.1.ebuild

38 lines
811 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
# ebuild generated by hackport 0.4.9999
#hackport: flags: -usenativewindowslibraries
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="GLURaw"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="A raw binding for the OpenGL graphics system"
HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~sparc x86"
IUSE=""
RDEPEND=">=dev-haskell/openglraw-1.3.0.0:=[profile?]
>=dev-lang/ghc-7.4.1:=
virtual/glu
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
--flag=-usenativewindowslibraries
}