You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild

62 lines
1.4 KiB

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# ebuild generated by hackport 0.6.1.9999
#hackport: flags: buildtests:test
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="HDBC"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Haskell Database Connectivity"
HOMEPAGE="https://github.com/hdbc/hdbc"
SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="2/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="test" # Requires dev-haskell/testpack (deprecated), and this is a problem.
RDEPEND=">=dev-haskell/convertible-1.1.0.0:=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/old-locale:=[profile?]
dev-haskell/old-time:=[profile?]
dev-haskell/text:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
test? ( dev-haskell/hunit:=[profile?]
>=dev-haskell/quickcheck-2.0:2=[profile?]
>=dev-haskell/testpack-2.0:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
"
S="${WORKDIR}/${MY_P}"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag test buildtests)
}
src_test() {
# default tests
haskell-cabal_src_test || die "cabal test failed"
# built custom tests
"${S}/dist/build/runtests/runtests" || die "unit tests failed"
}
src_install() {
cabal_src_install
# if tests were enabled, make sure the unit test driver is deleted
rm -f "${ED}/usr/bin/runtests"
}