You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Canary-Stability/Canary-Stability-2012.0.0.e...

25 lines
700 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=MLEHMANN
DIST_VERSION=2012
inherit perl-module
DESCRIPTION="Canary to check perl compatibility for schmorp's modules"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
"
src_test() {
perl-module_src_test
perl -Mblib="${S}" -M"Canary::Stability ${DIST_VERSION} ()" -e1 ||
die "Could not load Canary::Stability"
}