You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/File-MimeInfo/File-MimeInfo-0.270.0.ebuild

35 lines
758 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=MICHIELB
MODULE_VERSION=0.27
inherit perl-module
DESCRIPTION="Determine file type"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-perl/File-BaseDir-0.03
>=dev-perl/File-DesktopEntry-0.0
x11-misc/shared-mime-info"
DEPEND="${RDEPEND}
dev-perl/Module-Build
test? (
virtual/perl-Test-Simple
)
virtual/perl-ExtUtils-MakeMaker"
SRC_TEST="do parallel"
src_test() {
perl_rm_files t/08_changes.t t/06_pod_ok.t t/07_pod_cover.t \
t/09_no404s.t
perl-module_src_test
}