You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Inline/Inline-0.500.0-r1.ebuild

30 lines
582 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
MODULE_AUTHOR=SISYPHUS
MODULE_VERSION=0.50
inherit perl-module
DESCRIPTION="Write Perl subroutines in other languages"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="virtual/perl-Digest-MD5
virtual/perl-File-Spec
dev-perl/Parse-RecDescent"
DEPEND="${RDEPEND}
test? (
dev-perl/Test-Warn
)"
SRC_TEST=do
src_test() {
MAKEOPTS+=" -j1" perl-module_src_test # bug 384137
}