You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/automat/automat-0.5.0.ebuild

52 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_6)
inherit distutils-r1
MYPN="Automat"
MYP="${MYPN}-${PV}"
DESCRIPTION="Self-service finite-state machines for the programmer on the go"
HOMEPAGE="https://github.com/glyph/automat https://pypi.org/project/Automat/"
SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="examples test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-python/attrs[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
dev-python/setuptools_scm[${PYTHON_USEDEP}]
dev-python/m2r[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
S=${WORKDIR}/${MYP}
python_test() {
PYTHONPATH="${S}/test:${BUILD_DIR}/lib" py.test -v || die "Tests failed under ${EPYTHON}"
}
src_install() {
if use examples; then
docinto examples
dodoc docs/examples/*.py
fi
distutils-r1_src_install
}
pkg_postinst() {
einfo "For additional visualization functionality install these optional dependencies"
einfo " >=dev-python/twisted-16.1.1"
einfo " media-gfx/graphviz[python]"
}