You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/configshell/configshell-1.6.ebuild

30 lines
688 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="ConfigShell Community Edition for target_core_mod/ConfigFS"
HOMEPAGE="http://linux-iscsi.org/wiki/targetcli"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Datera/${PN}.git"
KEYWORDS=""
else
SRC_URI="https://github.com/Datera/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
DEPEND="dev-python/epydoc[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}
dev-python/urwid[${PYTHON_USEDEP}]"