You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/errorhandler/errorhandler-1.1.1-r2.ebuild

50 lines
1.1 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Logging framework handler that tracks when messages above a certain level have been logged"
HOMEPAGE="https://pypi.org/project/errorhandler/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="amd64 x86"
IUSE="doc"
LICENSE="MIT"
SLOT="0"
RDEPEND=""
DEPEND="
dev-python/pkginfo[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
PATCHES=(
"${FILESDIR}"/${P}-test.patch
"${FILESDIR}"/docs.patch
)
python_prepare_all() {
sed -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' -i docs/Makefile || die
distutils-r1_python_prepare_all
}
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
"${PYTHON}" -c "import errorhandler.tests as et, unittest; \
unittest.TextTestRunner().run(et.test_suite())" \
|| die "Tests fail with ${EPYTHON}"
}
python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}