You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/flask-uploads/flask-uploads-0.2.0-r1.ebuild

31 lines
853 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Flexible and efficient upload handling for Flask"
HOMEPAGE="https://pythonhosted.org/Flask-Testing/
https://pypi.org/project/Flask-Testing/"
SRC_URI="https://github.com/maxcountryman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
# use the GitHub tarball since the pypi-tarball does not contain the tests
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/flask-0.5[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
PATCHES=( "${FILESDIR}/${P}-remove-deprecated-module.patch" )
python_test() {
nosetests || die "Testing failed with ${EPYTHON}"
}