You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/gevent-socketio/gevent-socketio-0.3.6.ebuild

30 lines
737 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="SocketIO server based on the Gevent pywsgi server"
HOMEPAGE="https://pypi.org/project/gevent-socketio/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-python/gevent-websocket[${PYTHON_USEDEP}]
dev-python/gevent[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/versiontools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}] )"
python_test() {
py.test -v || die
}