You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1....

23 lines
639 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7} )
inherit distutils-r1
DESCRIPTION="Google Authentication Library"
HOMEPAGE="https://pypi.org/project/google-auth-oauthlib/ https://github.com/googleapis/google-auth-library-python-oauthlib"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/click[${PYTHON_USEDEP}]
dev-python/google-auth[${PYTHON_USEDEP}]
>=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
"