You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/guessit/guessit-9999.ebuild

50 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_6} )
inherit distutils-r1 git-r3
DESCRIPTION="Python library for guessing information from video filenames"
HOMEPAGE="https://github.com/guessit-io/guessit https://pypi.org/project/guessit/"
EGIT_REPO_URI="https://github.com/guessit-io/guessit.git"
EGIT_BRANCH="develop"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS=""
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
>=dev-python/rebulk-0.9.0[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
>=dev-python/pytest-3.4[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
)
"
python_prepare_all() {
# Disable benchmarks as they require unavailable pytest-benchmark.
rm guessit/test/test_benchmark.py || die
sed -i -e "s|'pytest-benchmark',||g" setup.py || die
# Disable unconditional dependency on dev-python/pytest-runner.
sed -i -e "s|'pytest-runner'||g" setup.py || die
distutils-r1_python_prepare_all
}
python_test() {
esetup.py test
}