You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/ijson/ijson-2.4.ebuild

25 lines
605 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="Iterative JSON parser with a Pythonic interface"
HOMEPAGE="https://github.com/isagalaev/ijson https://pypi.org/project/ijson/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="dev-libs/yajl"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
# pypi release lacks tests and git release isn't tagged yet
# python_test() {
# ${EPYTHON} tests.py || die
# }