You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/ijson/ijson-2.5.1.ebuild

24 lines
575 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="Iterative JSON parser with a Pythonic interface"
HOMEPAGE="https://github.com/ICRAR/ijson https://pypi.org/project/ijson/"
SRC_URI="https://github.com/ICRAR/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="dev-libs/yajl"
DEPEND="${RDEPEND}"
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
"${EPYTHON}" tests.py -v || die
}