You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/jedi/jedi-0.12.0.ebuild

47 lines
1.0 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_6 )
inherit distutils-r1
DESCRIPTION="Autocompletion library for Python"
HOMEPAGE="https://github.com/davidhalter/jedi"
SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
IUSE="doc test"
RDEPEND=">=dev-python/parso-0.1.1[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx )
test? (
dev-python/pytest[${PYTHON_USEDEP}]
${RDEPEND}
)"
# various misc failures
RESTRICT="test"
src_prepare() {
distutils-r1_python_prepare_all
}
python_test() {
PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test -v test \
|| die "Tests failed under ${EPYTHON}"
}
python_compile_all() {
use doc && emake -C docs html
}
python_install_all() {
use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
distutils-r1_python_install_all
}