You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/mako/mako-1.1.0.ebuild

51 lines
1.1 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
inherit distutils-r1 eutils
MY_PN="Mako"
MY_P=${MY_PN}-${PV}
DESCRIPTION="A Python templating language"
HOMEPAGE="http://www.makotemplates.org/ https://pypi.org/project/Mako/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="doc test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/markupsafe-0.9.2[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' pypy python2_7)
dev-python/pytest[${PYTHON_USEDEP}]
)
"
S="${WORKDIR}/${MY_P}"
python_test() {
py.test -v || die "Tests fail with ${EPYTHON}"
}
python_install_all() {
rm -r doc/build || die
use doc && local HTML_DOCS=( doc/. )
distutils-r1_python_install_all
}
pkg_postinst() {
elog "Optional dependencies:"
optfeature "caching support" dev-python/beaker
}