You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/mongoengine/mongoengine-0.10.6.ebuild

33 lines
810 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_6,3_7} )
inherit distutils-r1
RESTRICT="test" # connects to local DB and other nonsense
DESCRIPTION="A Python Object-Document-Mapper for working with MongoDB"
HOMEPAGE="https://github.com/MongoEngine/mongoengine/"
SRC_URI="https://github.com/MongoEngine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
RDEPEND=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/pymongo[${PYTHON_USEDEP}]"
python_prepare_all() {
sed -i -e 's/tests/tests*/g' setup.py || die "Failed to fix test removal thingy"
distutils-r1_python_prepare_all
}
python_test() {
nosetests || die "Testing failed with ${EPYTHON}"
}