You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/oslo-log/oslo-log-3.44.1.ebuild

42 lines
1.3 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="OpenStack logging config library, configuration for all openstack projects."
HOMEPAGE="https://pypi.org/project/oslo.log/ https://github.com/openstack/oslo.log"
SRC_URI="mirror://pypi/o/oslo.log/oslo.log-${PV}.tar.gz"
S="${WORKDIR}/oslo.log-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
CDEPEND=">=dev-python/pbr-3.1.1[${PYTHON_USEDEP}]"
RDEPEND="
${CDEPEND}
>=dev-python/six-1.11.0[${PYTHON_USEDEP}]
>=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
>=dev-python/oslo-context-2.20.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-3.20.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.36.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.25.0[${PYTHON_USEDEP}]
>=dev-python/debtcollector-1.19.0[${PYTHON_USEDEP}]
>=dev-python/pyinotify-0.9.6[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.7.0[${PYTHON_USEDEP}]
>=dev-python/monotonic-1.4[${PYTHON_USEDEP}]"
DEPEND="${CDEPEND}"
python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}
python_test() {
nosetests oslo_log/tests || die "Tests fail with ${EPYTHON}"
}