You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pyaudio/pyaudio-0.2.11.ebuild

37 lines
714 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python{2_7,3_6} )
inherit distutils-r1
MY_PN="PyAudio"
DESCRIPTION="Python bindings for PortAudio"
HOMEPAGE="http://people.csail.mit.edu/hubert/pyaudio/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="doc"
RDEPEND="media-libs/portaudio"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )"
S=${WORKDIR}/PyAudio-${PV}
src_compile() {
distutils-r1_src_compile
use doc && emake docs
}
python_install_all() {
use doc && local HTML_DOCS=( docs/. )
distutils-r1_python_install_all
}