You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pydot/pydot-1.0.28-r2.ebuild

28 lines
715 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Python interface to Graphviz's Dot language"
HOMEPAGE="https://pypi.org/project/pydot/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
IUSE=""
RDEPEND="
dev-python/pyparsing[${PYTHON_USEDEP}]
media-gfx/graphviz"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
PATCHES=(
"${FILESDIR}"/${PN}-1.0.23-setup.patch
"${FILESDIR}"/${P}-pyparsing2fix.patch )