You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/python-prctl/python-prctl-1.7.ebuild

22 lines
491 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="Control process attributes through prctl"
HOMEPAGE="https://github.com/seveas/python-prctl"
SRC_URI="https://github.com/seveas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="sys-libs/libcap"
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"