You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pywinrm/pywinrm-0.3.0.ebuild

26 lines
682 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Windows Remote Management through Python"
HOMEPAGE="https://pypi.org/project/pywinrm/"
SRC_URI="mirror://pypi/p/pywinrm/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
RDEPEND="dev-python/xmltodict[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/requests-credssp[${PYTHON_USEDEP}]
dev-python/requests-kerberos[${PYTHON_USEDEP}]
dev-python/requests-ntlm[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"