You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/redlock-py/redlock-py-1.0.8.ebuild

22 lines
545 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( pypy3 python3_6 )
inherit distutils-r1
DESCRIPTION="Redis distributed locks in Python"
HOMEPAGE="https://github.com/SPSCommerce/redlock-py https://pypi.org/project/redlock-py/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
CDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${CDEPEND}"
RDEPEND="${CDEPEND}"