You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalyti...

28 lines
707 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Sphinx extension googleanalytics"
HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
KEYWORDS="amd64 arm64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
PATCHES=( "${FILESDIR}/setup.py.utf-8.patch" )
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die
}