You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/toml/toml-0.10.0.ebuild

23 lines
589 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python{2_7,3_6,3_7} pypy3 )
inherit distutils-r1
DESCRIPTION="Python library for handling TOML files"
HOMEPAGE="https://github.com/uiri/toml"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~sparc ~x86"
# peculiar testing depending on https://github.com/BurntSushi/toml-test. Not
# particularly worth the trouble.
RESTRICT="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"