You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/tooz/tooz-1.60.1.ebuild

40 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1
DESCRIPTION="Library centralizing the most common distributed primitives"
HOMEPAGE="http://docs.openstack.org/developer/tooz/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
IUSE=""
CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}"
RDEPEND="${CDEPEND}
>=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
virtual/python-enum34[${PYTHON_USEDEP}]
>=dev-python/voluptuous-0.8.9[${PYTHON_USEDEP}]
>=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
>=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
>=dev-python/tenacity-3.2.1[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
>=dev-python/futurist-0.11.0[${PYTHON_USEDEP}]
!~dev-python/futurist-0.15.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]"
python_prepare_all() {
# allow useage of renamed msgpack
sed -i '/^msgpack/d' requirements.txt || die
distutils-r1_python_prepare_all
}