You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/wsgiproxy2/wsgiproxy2-0.4.6.ebuild

50 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit distutils-r1
MY_PN="WSGIProxy2"
DESCRIPTION="HTTP proxying tools for WSGI apps"
HOMEPAGE="https://pypi.org/project/WSGIProxy2/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86"
RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]
dev-python/webob[${PYTHON_USEDEP}]
"
BDEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
>=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
dev-python/socketpool[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/restkit[${PYTHON_USEDEP}]' -2)
)"
# Tests needing restkit are skipped under py3
# Testing also revealed the suite needs latest webtest
S="${WORKDIR}/${MY_PN}-${PV}"
PATCHES=(
"${FILESDIR}/wsgiproxy2-0.4.6-tests.patch"
)
distutils_enable_sphinx docs
distutils_enable_tests nose
python_prepare_all() {
sed -i '/with-coverage/ d' setup.cfg || die
distutils-r1_python_prepare_all
}