You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/wtf-peewee/wtf-peewee-3.0.0.ebuild

31 lines
777 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_6 )
inherit distutils-r1
DESCRIPTION="WTForms integration for peewee models"
HOMEPAGE="https://github.com/coleifer/wtf-peewee/"
SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="examples test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/peewee-3[${PYTHON_USEDEP}]
dev-python/wtforms[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
"${PYTHON}" ./runtests.py || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
use examples && dodoc -r example
distutils-r1_python_install_all
}