You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ros/fake_localization/fake_localization-1.16.2.eb...

31 lines
803 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
ROS_REPO_URI="https://github.com/ros-planning/navigation"
ROS_SUBDIR=${PN}
KEYWORDS="~amd64 ~arm"
PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
DESCRIPTION="A ROS node that simply forwards odometry information"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-libs/boost:=
dev-ros/angles
dev-ros/roscpp
dev-ros/rospy[${PYTHON_USEDEP}]
dev-ros/rosconsole
dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2_ros
dev-ros/message_filters
dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}/boost170.patch" )