You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ros/rqt_dep/rqt_dep-9999.ebuild

27 lines
647 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_dep"
PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
DESCRIPTION="GUI plugin for visualizing the ROS dependency graph"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-python/rospkg[${PYTHON_USEDEP}]
dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
dev-ros/qt_gui[${PYTHON_USEDEP}]
dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
dev-ros/rqt_graph[${PYTHON_USEDEP}]
dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"