You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ros/urg_node/urg_node-0.1.11.ebuild

31 lines
679 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
KEYWORDS="~amd64 ~arm"
PYTHON_COMPAT=( python2_7 )
CATKIN_HAS_MESSAGES=yes
inherit ros-catkin
DESCRIPTION="ROS wrapper for the Hokuyo urg_c library"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-ros/urg_c
dev-ros/tf
dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
dev-ros/nodelet
dev-ros/rosconsole
dev-ros/roscpp
dev-ros/diagnostic_updater
dev-ros/laser_proc
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-libs/boost:=
"
DEPEND="${RDEPEND}"