You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/optimist/optimist-3.0.0.ebuild

30 lines
771 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
USE_RUBY="ruby23 ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.md"
inherit ruby-fakegem
DESCRIPTION="A commandline option parser for Ruby that just gets out of your way."
HOMEPAGE="https://manageiq.github.io/optimist/"
LICENSE="MIT"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT="3"
IUSE=""
ruby_add_bdepend "test? ( dev-ruby/chronic )"
all_ruby_prepare() {
sed -i -e '/bundle/ s:^:#:' Rakefile || die
}
each_ruby_test() {
MUTANT=true ${RUBY} -S rake test || die "Tests failed."
}