You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/rex-nop/rex-nop-0.1.1.ebuild

28 lines
533 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
USE_RUBY="ruby23 ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="none"
RUBY_FAKEGEM_BINWRAP=""
inherit ruby-fakegem
DESCRIPTION="Rex library for dynamic generation of x86 multi-byte NOPs"
HOMEPAGE="https://rubygems.org/gems/rex-nop"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
ruby_add_rdepend "dev-ruby/rex-arch"
all_ruby_prepare() {
sed -i '/bundler/d' Rakefile
}