You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-apps/kitinerary/kitinerary-19.12.1.ebuild

44 lines
978 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ECM_TEST="forceoptional"
PVCUT=$(ver_cut 1-3)
KFMIN=5.63.0
QTMIN=5.12.3
VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
HOMEPAGE="https://kde.org/applications/office/org.kde.kontact"
LICENSE="LGPL-2.1+"
SLOT="5"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="+barcode"
DEPEND="
>=dev-qt/qtdeclarative-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=kde-frameworks/karchive-${KFMIN}:5
>=kde-frameworks/kcalendarcore-${KFMIN}:5
>=kde-frameworks/kcontacts-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-apps/kmime-${PVCUT}:5
>=kde-apps/kpkpass-${PVCUT}:5
app-text/poppler:=[qt5]
sys-libs/zlib
barcode? ( media-libs/zxing-cpp )
"
RDEPEND="${DEPEND}
!<kde-apps/kdepim-addons-18.07.80
"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package barcode ZXing)
)
ecm_src_configure
}