You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-apps/kldap/kldap-19.12.1.ebuild

42 lines
896 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ECM_HANDBOOK="forceoptional"
ECM_TEST="true"
KFMIN=5.63.0
QTMIN=5.12.3
inherit ecm kde.org
DESCRIPTION="Library for interacting with LDAP servers"
HOMEPAGE="https://api.kde.org/kdepim/kldap/html/index.html"
LICENSE="GPL-2+"
SLOT="5"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE=""
DEPEND="
>=kde-frameworks/kcompletion-${KFMIN}:5
>=kde-frameworks/ki18n-${KFMIN}:5
>=kde-frameworks/kio-${KFMIN}:5
>=kde-frameworks/kwidgetsaddons-${KFMIN}:5
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
dev-libs/cyrus-sasl
net-nds/openldap
"
RDEPEND="${DEPEND}
!kde-apps/kdepim-l10n
"
src_prepare() {
ecm_src_prepare
if ! use handbook ; then
sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
-i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
fi
}