You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kapidox/kapidox-5.66.0.ebuild

25 lines
554 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_SINGLE_IMPL="true"
PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake kde.org distutils-r1
DESCRIPTION="Framework for building KDE API documentation in a standard format and style"
LICENSE="BSD-2"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE=""
RDEPEND="
app-doc/doxygen
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
media-gfx/graphviz[python,${PYTHON_USEDEP}]
"
pkg_setup() {
python-single-r1_pkg_setup
}