You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kcontacts/kcontacts-5.64.0.ebuild

37 lines
761 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ECM_TEST="true"
PVCUT=$(ver_cut 1-2)
QTMIN=5.12.3
VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="Address book API based on KDE Frameworks"
LICENSE="GPL-2+"
KEYWORDS="amd64 arm64 x86"
IUSE=""
DEPEND="
>=kde-frameworks/kcodecs-${PVCUT}:5
>=kde-frameworks/kconfig-${PVCUT}:5
>=kde-frameworks/kcoreaddons-${PVCUT}:5
>=kde-frameworks/ki18n-${PVCUT}:5
>=dev-qt/qtgui-${QTMIN}:5
"
RDEPEND="${DEPEND}
!kde-apps/kcontacts:5
!kde-apps/kdepim-l10n
app-text/iso-codes
"
src_test() {
# bug #566648 (access to /dev/dri/card0 denied), bug #625988
local myctestargs=(
-E "(kcontacts-addresstest|kcontacts-picturetest)"
)
ecm_src_test
}