You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/mail-filter/libsrs2/libsrs2-1.0.18.ebuild

34 lines
646 B

# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit eutils autotools
DESCRIPTION="libsrs2 is the next generation Sender Rewriting Scheme library"
HOMEPAGE="http://www.libsrs2.org/"
SRC_URI="http://www.libsrs2.org/srs/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="static-libs"
DEPEND="!dev-perl/Mail-SRS"
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}-parallel-make.diff"
eautoreconf
}
src_configure() {
econf \
$(use_enable static-libs static)
}
src_install() {
default
use static-libs || find "${D}" -name '*.la' -delete
}