You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-radio/xastir/xastir-2.0.8-r1.ebuild

87 lines
2.2 KiB

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit autotools eutils flag-o-matic toolchain-funcs
DESCRIPTION="X Amateur Station Tracking and Information Reporting"
HOMEPAGE="http://xastir.org/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="gdal geotiff +graphicsmagick"
DEPEND=">=x11-libs/motif-2.3:0
x11-libs/libXt
x11-libs/libX11
x11-libs/libXpm
x11-apps/xfontsel
dev-libs/libpcre
net-misc/curl
sys-libs/db:4.8
sci-libs/shapelib
!graphicsmagick? ( <media-gfx/imagemagick-7:0=[-hdri,-q32] )
graphicsmagick? ( media-gfx/graphicsmagick:=[-q32] )
geotiff? ( sci-libs/proj
sci-libs/libgeotiff
media-libs/tiff:0 )
gdal? ( sci-libs/gdal )"
RDEPEND="${DEPEND}"
src_prepare() {
# fix script location (bug #407185)
epatch "${FILESDIR}"/${P}-scripts.diff
# fix __FORTIFY_SOURCE warning (bug #337365)
epatch "${FILESDIR}"/${PN}-2.0.4-fortify.diff
# do not use builtin shapelib if sci-libs/shapelib is not installed
# instead build without shapelib support (bug #430704)
epatch "${FILESDIR}"/${P}-no-builtin-shapelib.diff
# do not filter duplicate flags (see bug 411095)
epatch "${FILESDIR}"/${PN}-2.0.0-dont-filter-flags.diff
# fix compile problem with newer graphicsmagic
epatch "${FILESDIR}"/${PN}-2.0.8-fix-graphicsmagick.diff
eautoreconf
}
src_configure() {
# provide include path to GraphicsMagic for configure stage
use graphicsmagick && append-cflags -I/usr/include/GraphicsMagick
econf --with-pcre \
--with-shapelib \
--with-dbfawk \
--without-ax25 \
--without-festival \
--without-gpsman \
$(use_with !graphicsmagick imagemagick) \
$(use_with graphicsmagick) \
$(use_with geotiff libproj) \
$(use_with geotiff) \
$(use_with gdal)
}
src_compile() {
emake AR="$(tc-getAR)"
}
src_install() {
emake DESTDIR="${D}" install
rm -rf "${D}"/usr/share/doc/${PN}
dodoc AUTHORS ChangeLog FAQ README README.Contributing \
README.Getting-Started README.MAPS
}
pkg_postinst() {
elog "Kernel mode AX.25 and GPSman library not supported."
elog
elog "Remember you have to be root to add addditional scripts,"
elog "maps and other configuration data under /usr/share/xastir."
}