You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-im/yowsup/yowsup-3.2.3.ebuild

41 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
PYTHON_REQ_USE="readline"
inherit distutils-r1
DESCRIPTION="A library that enables you to build applications which use the WhatsApp service"
HOMEPAGE="https://github.com/tgalal/yowsup"
SRC_URI="https://github.com/tgalal/yowsup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="
dev-python/appdirs[${PYTHON_USEDEP}]
dev-python/configargparse[${PYTHON_USEDEP}]
dev-python/consonance[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/protobuf-python[${PYTHON_USEDEP}]
dev-python/python-axolotl[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
PATCHES=( "${FILESDIR}/${P}-fix-install-path.patch" )
pkg_postinst() {
einfo "Warning: It seems that recently yowsup gets detected during registration"
einfo "resulting in an instant ban for your number right after registering"
einfo "with the code you receive by sms/voice."
einfo "See https://github.com/tgalal/yowsup/issues/2829 for more information."
}