You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/wandio/wandio-4.2.1.ebuild

49 lines
939 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="C library for simple and efficient file IO"
HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
SRC_URI="https://github.com/wanduow/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0/6"
KEYWORDS="~amd64 ~x86"
IUSE="bzip2 http lzma lzo static-libs test zlib"
RESTRICT="!test? ( test )"
RDEPEND="
!<net-libs/libtrace-4
bzip2? ( app-arch/bzip2 )
lzma? ( app-arch/xz-utils )
lzo? ( dev-libs/lzo )
http? ( net-misc/curl )
zlib? ( sys-libs/zlib )
"
DEPEND="
${RDEPEND}
test? ( app-arch/lzop )
"
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_enable static-libs static) \
$(use_with bzip2) \
$(use_with http) \
$(use_with lzma) \
$(use_with lzo) \
$(use_with zlib)
}
src_test() {
pushd test || die
sh do-basic-tests.sh
}