You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-news/rsstail/rsstail-1.8.ebuild

32 lines
595 B

# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit toolchain-funcs
DESCRIPTION="A tail-like RSS-reader"
HOMEPAGE="http://www.vanheusden.com/rsstail/"
SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=">=net-libs/libmrss-0.17.1"
RDEPEND="${DEPEND}"
src_compile() {
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS} -DVERSION=\\\"\$(VERSION)\\\"" \
LDFLAGS="${LDFLAGS} -lmrss"
}
src_install() {
dobin rsstail
doman rsstail.1
newdoc readme.txt README
}