You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-wireless/gr-air-modes/gr-air-modes-9999.ebuild

47 lines
955 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python2_7 )
if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/bistromath/gr-air-modes.git"
EGIT_BRANCH="master"
else
KEYWORDS=""
fi
inherit cmake-utils python-single-r1
DESCRIPTION="This module implements a complete Mode S and ADS-B receiver for Gnuradio"
HOMEPAGE="https://www.cgran.org/wiki/gr-air-modes"
LICENSE="GPL-3"
SLOT="0"
IUSE="fgfs rtlsdr uhd"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
dev-python/pyzmq[${PYTHON_USEDEP}]
>=net-wireless/gnuradio-3.7.0:=
net-wireless/gr-osmosdr
fgfs? (
games-simulation/flightgear
sci-libs/scipy
)
rtlsdr? ( net-wireless/rtl-sdr )
uhd? ( >=net-wireless/uhd-3.4.0 )
"
RDEPEND="${DEPEND}"
src_compile() {
cmake-utils_src_compile -j1
}
src_install() {
cmake-utils_src_install
python_fix_shebang "${ED}"/usr/bin
}