You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-electronics/pulseview/pulseview-9999.ebuild

62 lines
1.2 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python3_{6,7} )
inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
inherit git-r3
else
SRC_URI="https://sigrok.org/download/source/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Qt based logic analyzer GUI for sigrok"
HOMEPAGE="https://sigrok.org/wiki/PulseView"
LICENSE="GPL-3"
SLOT="0"
IUSE="+decode static"
REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
>=dev-libs/boost-1.55:=
>=dev-libs/glib-2.28.0:2
>=dev-cpp/glibmm-2.28.0:2
>=sci-libs/libsigrok-0.6.0:=[cxx]
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtsvg:5
decode? (
>=sci-libs/libsigrokdecode-0.6.0:=[${PYTHON_USEDEP}]
${PYTHON_DEPS}
)"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( HACKING NEWS README )
src_configure() {
local mycmakeargs=(
-DDISABLE_WERROR=TRUE
-DENABLE_DECODE=$(usex decode)
-DSTATIC_PKGDEPS_LIBS=$(usex static)
)
cmake-utils_src_configure
}
pkg_postinst() {
gnome2_icon_cache_update
xdg_desktop_database_update
}
pkg_postrm() {
gnome2_icon_cache_update
xdg_desktop_database_update
}