You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-physics/siscone/siscone-3.0.3.ebuild

32 lines
676 B

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="Hadron Seedless Infrared-Safe Cone jet algorithm"
HOMEPAGE="http://siscone.hepforge.org/"
SRC_URI="http://www.hepforge.org/archive/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples static-libs"
RDEPEND=""
DEPEND="${RDEPEND}"
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
if use examples; then
docinto examples
dodoc examples/*.{cpp,h}
docinto examples/events
dodoc examples/events/*.dat
docompress -x /usr/share/doc/${PF}/examples
fi
}