You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/cpint/cpint-2.5.3.ebuild

32 lines
650 B

# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
inherit linux-info eutils
MY_PV=${PV//./}
DESCRIPTION="Linux/390 Interface to z/VM's Control Program"
HOMEPAGE="http://linuxvm.org/Patches/index.html"
SRC_URI="http://linuxvm.org/Patches/s390/${PN}${MY_PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="s390"
IUSE=""
src_prepare() {
epatch "${FILESDIR}"/${P}-build.patch
epatch "${FILESDIR}"/${P}-prototypes.patch
epatch "${FILESDIR}"/${P}-kernel.patch
# the makefile uses this variable
export KERNEL_DIR
}
src_install() {
emake install prefix="${D}"
dodoc ChangeLog HOW-TO
}