You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/elivepatch-client/elivepatch-client-9999.ebuild

29 lines
731 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_6} )
inherit distutils-r1
DESCRIPTION="Live patch installer client working with elivepatch-server"
HOMEPAGE="https://wiki.gentoo.org/wiki/Elivepatch"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/aliceinwire/elivepatch-client.git"
else
SRC_URI="https://github.com/aliceinwire/elivepatch-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
LICENSE="GPL-2+"
SLOT="0"
RDEPEND="
app-admin/sudo
dev-python/git-python[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"