You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/texinfo/texinfo-6.6-r1.ebuild

46 lines
1.3 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Note: if your package uses the texi2dvi utility, it must depend on the
# virtual/texi2dvi package to pull in all the right deps. The tool is not
# usable out-of-the-box because it requires the large tex packages.
EAPI=6
inherit flag-o-matic toolchain-funcs
DESCRIPTION="The GNU info program and utilities"
HOMEPAGE="https://www.gnu.org/software/texinfo/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86"
IUSE="nls static"
RDEPEND="
!=app-text/tetex-2*
>=sys-libs/ncurses-5.2-r2:0=
dev-lang/perl:=
dev-perl/libintl-perl
dev-perl/Unicode-EastAsianWidth
dev-perl/Text-Unidecode
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
app-arch/xz-utils
nls? ( >=sys-devel/gettext-0.19.6 )"
src_configure() {
# Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions. #622576
local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}" PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
use static && append-ldflags -static
local myeconfargs=(
--with-external-libintl-perl
--with-external-Unicode-EastAsianWidth
--with-external-Text-Unidecode
$(use_enable nls)
)
econf "${myeconfargs[@]}"
}